Start a new topic

Consistently getting error on "Valid RR"

 I'm about to smash my iphone and HR monitor into bits. I've tried all of the troubleshooting tips but can't get the Valid RR to stay green. Before you ask, I've:

- stayed perfectly still

- tried sitting and standing

- turned my phone off and on

- removed the battery and wiped it off

Do I need to replace the battery? Chuck it all in the river? Something else?

Thanks for any help you have!


1 person has this question
Lol!! I have had the same issues!! I am wondering if the android version is more reliable? I have found that if you take the battery out of the Bluetooth, but the cover back on and attach your Bluetooth to the receiver strap without the battery and wear it for about 5min, then take it off and reinsert the battery and wear it again, it works. I've also found doing a full power off on my iPad first (before doing the steps I wrote above) and then turning it back on before I start also seems to help. Reaaalllllly frustrating though....not going to lie. I miss the days where I could just get up and take a reading and everything worked. The last 4-6 months have been super inconsistent and frustrating. It seems like every IOS update messes up my readings and there are updates like every 2 weeks. I'm hoping to hear that the android version is more reliable because Im prepared to buy another device if it will let me get back to using this tool more consistently. Also.... On an unrelated note can I just say how much I love your cookbooks?!!! :)

Thanks for the tips -- although that does sound like a bummer ;-) I'll give it a try.

And thank you for the sweet words about our cookbooks. I'm really glad you like them! Happy cooking to you! Wishing you excellent health and happiness in the new year.

I have been having these same issues, and feel your frustrations! taking the battery out and wiping it off seems to be the best solution I have found. Are you still having issues? The trouble I am now having is that the little plastic back that holds the battery in is busted. And held on by some tape...wondering if you had any new insights? I replaced my battery and it worked well for a very peaceful week...

Hey Lindsay,

I'm going to try replacing the receiver belt. I have been using Bioforce daily since June 2013. Usually replacing the batter or taking it out and wiping it was failsafe. Neither have those worked for quite some time so I'm pretty sure I just wore the life out of the receiver. It's definitely worth a shot.

I keep getting this error as well.  I am using a Polar Bluetooth monitor, which I've had to short out once.  Is it time for a new monitor?  I've already tried the things that Mel listed.  If I need a new monitor, which one do you recommend?

Login to post a comment